-1 byte/ no iso when it says its done solution-->

Discussion about Avi2Dvd.
Requests and bug fixing.

Moderators: george, Excalibur!, skyheartblue, roger_rabbit, reburn

-1 byte/ no iso when it says its done solution-->

Postby erithid » Tue Sep 26, 2006 3:05 am

Hello, I don't know if this will work for everyone, but it fixed things for me. If you search your computer for cygwin1.dll and more than 1 entry shows up that will cause avi2dvd to fail. delete all but the newewst(or the one that is in c:/cygwin/bin) and then add c:/cgywin/bin to your path. Also, do not have cygwin runnign while avi2dvd is running because that is just asking for trouble. I hope this helps others! ~eri
Junior Member
Posts: 1
Joined: Tue Sep 26, 2006 3:01 am

Postby claudio » Tue Sep 26, 2006 10:49 am

I had that same problem recently, i will try it thanks!!
Junior Member
Posts: 13
Joined: Fri Jan 13, 2006 6:42 pm

Postby trustfm » Tue Sep 26, 2006 2:53 pm

great solution ! i will make that sticky ! Thanks !
Site Admin
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Postby claudio » Tue Sep 26, 2006 4:04 pm

Ok. i did what you said, and problem solved!! :D :D :D
Junior Member
Posts: 13
Joined: Fri Jan 13, 2006 6:42 pm

Encoded_Video, 0KB

Postby dan24 » Sun Jan 07, 2007 12:36 am

I get a complete audio stream, but no encoded video. I'm not sure the cygwin solution applies to me: I don't see this product , e.g. c:/cygwin/bin. How do I find cygwin1.dll?

Any other solutions to this problem of 0KB ISO?
Junior Member
Posts: 3
Joined: Sun Jan 07, 2007 12:18 am


Postby marcwallace » Wed May 02, 2007 12:38 pm

There is no cygwin.dll file on my comp, and i'm getting a 0kb video file. is thee anything else that you could suggest? i've been at this all day and tried all solutions but its still not working... might have to try another program if this keeps up.
Junior Member
Posts: 2
Joined: Wed May 02, 2007 12:29 pm

1 byte/no iso

Postby joebf » Sun May 06, 2007 2:28 am

What exactly do you mean by ".... delete all but the newewst(or the one that is in c:/cygwin/bin) and then add c:/cgywin/bin to your path". What path?
Junior Member
Posts: 3
Joined: Fri May 04, 2007 11:44 pm
Location: vancouver

Postby psychichigh » Wed Jul 04, 2007 10:05 pm

The filename you need to search for is cygwin1.dll (yes, there is a 1 in there... naming convention from when cygwin was first being developed to differentiate between cygwin dlls as they were messing around with stuff)

In windows XP, it's as easy as clicking the search button in windows. Just open My Computer and it's there. haven't used windows 95/98/me/2k in ages, and never used vista so I can't help out there.

once the search for "cygwin1.dll" is complete, you'll find at least one copy of cygwin1.dll (as long as avi2dvd is installed)
Just select all of them, except for one that's in "C:\cygwin\bin" )If you're like me, somehow you've managed to come up with more than just a couple currently I'm looking at 14 as I'm doing this post reply up :lol:) and press the delete button

Now that you've just eradicated the scum causing the problem, time to fix it up so it shouldn't happen again (unless you install another program that uses cygwin1.dll)
I windows XP, open up your Control Panel, and double click on System. Click on Advanced (don't let the title of the tab scare ya, it's not for windows or computer elitists. Just options you normally wouldn't change except under specific circumstances, and this is one) Then click the button at the bottom with the biggest tag "Environment Variables."
There are two boxes, 'User variables for yourlogin' and 'System Variables'
Under system variables scroll down till you see "Path C:\WINDOWS\system32;........"
Select it and then click Edit. Variable name you will leave as is, or else... (change it and reboot if you want to learn what it does, but make a system restore point first *hint hint* )
just append the following to the end of the text... without with the " "
and now Click OK, then OK again, and once again OK.

From here it'll be safe to encode that avi as dvd now, but as a safe bet I would recommend rebooting so the system flushes itself.

And there we have it. I know it works out because I just tested it. Thanks to erithid for the original problem solver, and trustfm for the great work on this collection of programs to make avi->dvd easy. And now we just need someone to proof read it for typos, grammar, and layout so it's actually easy to read other than my humble ramblings.
Junior Member
Posts: 2
Joined: Sun Feb 11, 2007 1:27 am

Postby mr_johnson » Sun Sep 02, 2007 7:08 pm

I just attempted this. Prior to trying, I removed Avi2Dvd from my PC for various reasons. The search resulted in 0 findings of cygwin1.dll. Leads me to believe that w/Avi2dvd installed only that programs version of cygwin1.dll is on my PC. Yet, I still received the dreaded '-1 byte, job not done, check log for 0 byte' error message.

Kudos to the original poster that found this solution which has worked for some of you.

Back to the drawing board for me.

Mr. Johnson
Junior Member
Posts: 5
Joined: Sun Sep 02, 2007 6:33 pm

My solution

Postby Aze » Sat Dec 01, 2007 1:26 pm

Hi everyone,

i also had the -1 byte video problem, so i read the forums and tried a lot of things
- the "simple file names and directory names" solution
- reinstalled everything
- installed new downloaded avisynth
- search for the cygwin1, but only one file existed

but what really worked and definitely solved the problem for me:

get rid of ffdshow and install XVID 1.1.3

Source file was xvid movie with 2 audio tracks (one 5.1 and one stereo). avi2dvd / avisynth crashed when starting the video transformation, no matter what codec used. The log looked like this:

Code: Select all
[14:01:02] AVI2DVD Started !
[14:01:03] Type mode : Avi Input
[14:01:03] Output : Dvd
[14:01:03] Encoder Selected : FreeEnc
[14:01:03] Start demuxing the AudioStream No.1 ...
[14:01:26] Demuxing of the selected audio finished
successfully !
349606656 Bytes]
[14:01:26] Starts Audio correction ...
[14:01:34] Audio Fixed successfully !
349606656 Bytes]
[14:01:34] Starts Ac3->Ac3 convertion ...
[14:01:34] Audio converted in Ac3 successfully !
[D:\dvdmovies\Avi2dvd_temp\AudioStream 1 AC3
6CH.ac3 349606656 Bytes]
[14:01:34] Start creating avisynth script ...
[14:01:34] Avisynth script created successfully !
148 Bytes]
[14:01:35] Bitrate used : 5286 Kbpps
[14:01:35] Start video encoding ...
[14:02:54] Video encoded successfully !
[D:\dvdmovies\Avi2dvd_temp\Encoded_Video.m2v -1
[14:02:54] Job NOT Done. There are warnings ... Find at
the log file the 0 byte generated file to focus where exactly
the problem appears

i had to delete the xvid.ax file in c:\windows\system32 manually after deinstalling ffdshow to be able to install xvid 1.1.3.
After that, avi2dvd and avisynth work fine!

Maybe this will work for some of you too, allthough i did really like ffdshow... maybe i will reinstall it without using it for xvid and divx-files.

edit: ffdshow-version was from july 2007, xvid is 1.1.3 (as allready mentioned)

Markus / Aze
Junior Member
Posts: 1
Joined: Sat Dec 01, 2007 1:18 pm


Return to Avi2Dvd

Who is online

Users browsing this forum: No registered users and 1 guest