Not working with Russian

Discussion about Txt2Vobsub. Requests and bug fixing.

Moderators: george, roger_rabbit

Not working with Russian

Postby citizen doctor » Mon Jun 22, 2009 5:38 am

I can't get Txt2Vosub to work with Russian.

Here is the content of test.srt:

1
00:00:05,900 --> 00:00:11,290
Это тест.

The character encoding is UTF-8.

I use Windows Vista, and have changed the "Current language for non uni-code programs" to Russian in the Administrative tab of the Regional and Language Options of the Control Panel.

This is what I see when I load test.srt:

Image
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby trustfm » Tue Jun 23, 2009 6:42 pm

go to start- control panel - regional settings - advanced(tab)- language for non unicode programs RUSSIAN
Restart your pc
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Postby citizen doctor » Tue Jun 23, 2009 9:18 pm

trustfm wrote:go to start- control panel - regional settings - advanced(tab)- language for non unicode programs RUSSIAN
Restart your pc


As mentioned above, I already did this.
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby citizen doctor » Thu Jun 25, 2009 5:27 am

I would like to add that my wife, who is Russian, uses this same computer extensively. We have many applications, a Russian keyboard, and we never have any problem properly displaying Russian characters, except in txt2vobsub.

I have spent three hours trying many different approaches. I tried 2 months ago also and gave up, but I am trying again because the other software I found to make Russian idx/sub files produces very poor characters. I am hoping yours can do better.

Thanks.
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby trustfm » Sat Jun 27, 2009 1:42 am

This is surely strange behaviur.
You get this on EVERY subtitle ?
I will try again to see where the problem can be found ...
Tip : try changing the font from arial to verdana or any other ...
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Postby citizen doctor » Mon Jun 29, 2009 12:00 pm

trustfm wrote:This is surely strange behaviur.
You get this on EVERY subtitle ?
I will try again to see where the problem can be found ...
Tip : try changing the font from arial to verdana or any other ...


Yes, I get it on every Russian subtitle...I've tried many, with several different character encodings besides utf-8.

I also tried many different fonts. Every font produces more letters than is in the original Russian. Therefore, it seems that each byte of the multi-byte utf-8 code is being treated as a separate character.
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby citizen doctor » Sat Jul 04, 2009 7:45 am

Hi again,

This time I tried Dutch, and almost the same thing is happening. Here is the experimental SRT file:

1
00:30:35,940 --> 00:30:41,310
kandidaten minstens ??n

2
00:30:48,200 --> 00:30:51,900
hun namen uit de offici?le

I have attached the screenshot. I changed the Vista System Locale to Dutch (Netherlands). I tried many different fonts and character sets. I notice the same thing as with Russian. In every case, the unusual characters like ? and ? get replaced by TWO other characters, indicating that the UTF-8 multibyte code is not being translated properly.

Image
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby trustfm » Tue Jul 07, 2009 2:19 am

mail me this subtitle at trustfm@gmail.com
Thanks
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Postby citizen doctor » Fri Jul 10, 2009 1:03 pm

trustfm wrote:mail me this subtitle at trustfm@gmail.com
Thanks


Hi,

I pasted a test SRT in Dutch into my last comment, but here it is again:

1
00:30:35,940 --> 00:30:41,310
kandidaten minstens ??n

2
00:30:48,200 --> 00:30:51,900
hun namen uit de offici?le

And I'll mail it also.
citizen doctor
Junior Member
 
Posts: 7
Joined: Mon Jun 22, 2009 5:23 am

Postby trustfm » Fri Jul 10, 2009 2:03 pm

I went to

start - control panel - regional and language options - advanced tab - Dutch
I rerstarted the computer

I loaded the given srt and i have this result :

Image

Is this result correct ? :?

The style is arial and the font charset is set to DEFAULT

I will try the same under vista (i have it on another computer please give me some time...)

Thanks !

----------------------------------------------------------------------------------------------------------------------

Later on vista :

Here the solution is even easyer.
I loaded the srt file (your srt dutchtest.srt)
I have selected EASTENEUROPE at the font charset (font is arial)
and i got the same result .

Question : Is the rendered picture correct? :roll:
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Next

Return to Txt2Vobsub

Who is online

Users browsing this forum: No registered users and 1 guest

cron