Possible Son2VobSub Bug

Discussion about Txt2Vobsub. Requests and bug fixing.

Moderators: george, roger_rabbit

Possible Son2VobSub Bug

Postby runner10 » Sat Nov 11, 2006 9:01 pm

Hello, I believe what I have found is a bug in Son2VobSub, and not a bug in Txt2VobSub, but I am posting here because it affects Txt2Vobsub.

It appears that vobsubs generated using Son2VobSub will contain any any random number of "Forced" subtitles. In other words, there is nothing in the SON which would specify that a subtitle be forced, and yet the output vobsub will contain one or more "forced" subtitles.

Note that I am checking for "forced" status by looking at the vobsub with subresync, so, I guess, technically it could be a bug in subresync, but since I only see this problem with son2vobsub-generated vobsubs, I think the problem is with son2vobsub.

I do not know vobsub structure, and so I have no idea how the forced property is designated. However, based on my tests, it appears that some peculiar property of a particular BMP will cause son2vobsub to generate a vobsub where the corresponding subtitle is "forced". If anyone knows how to contact the author of son2vobsub, I'd like to bring this issue to his/her attention.
runner10
Junior Member
 
Posts: 1
Joined: Mon Oct 30, 2006 7:42 pm

Postby trustfm » Wed Nov 21, 2007 1:51 pm

this problem is solved with the new version of txt2vobsub 3.0
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm


Return to Txt2Vobsub

Who is online

Users browsing this forum: No registered users and 1 guest

cron