Floating point division by zero error

Discussion about Avi2Dvd.
Requests and bug fixing.

Moderators: george, Excalibur!, skyheartblue, roger_rabbit, reburn

Floating point error despite all of the above

Postby tim564 » Sat Oct 07, 2006 9:02 pm

So I install XviD and check my hard-drive is NTFS...my first coversion works fine as does my second (despite an error regarding invalid characters in my file path but I sorted that). So now with my third conversion I am back with my first error again...??? I'm thinking it has to the file I'm converting, just a standard .avi
Junior Member
Posts: 1
Joined: Sat Oct 07, 2006 8:50 pm

Postby wbelhaven » Fri Nov 10, 2006 6:16 pm


I'm using NTFS and just installed the Xvid codec, but I'm still getting the Floating point divisiion by zero error every time I try to load an AVI. Any other suggestions?

Junior Member
Posts: 1
Joined: Fri Nov 10, 2006 6:12 pm

Postby trothem » Tue May 22, 2007 8:29 am

The "floating point division by zero" occurs with my beta 0.4.4 and with .avi files and only with them.
My disk is NTFS and I have Xvid installed.
From what I have read. I understand that this error is not consistent, occurs in dfferent cases
whith different kind of files (avi, mkv , ogm,...)
so I think that is something wrong with the program Avi2Dvd and not
with the codec or the NTFS or FAT or FAT32.

The .avi files are displayed OK with Media Player or Winamp and I do not have any
problem with them.

If someone has some solutions. please respond .
Thanx, Tuvia
Junior Member
Posts: 1
Joined: Mon May 21, 2007 8:14 pm

Postby tytycoon » Fri Nov 30, 2007 8:42 am

Goosfraba wrote:
stsong wrote:Thanks Shrike,
Installing Xvid solved the problem. here's the download http://www.xvidmovies.com/codec/

Damn, I just downloaded Xvid but nothing changes. Where do I look to see if I'm using NTFS or not? I don't even know what that is :shock:

In Windows XP (I have no Idea with Vista) To check your file System (that is, what kind of compression your file system has) Go into My Computer, Right-click on C: (or whatever hard drive letter you have) and click properties. It will say under 'File System' Something like 'NTFS' 'FAT32' or some other thing, but I believe all XP and Vista Systems default to NTFS.

Junior Member
Posts: 1
Joined: Fri Nov 30, 2007 8:38 am

Worked after using HCEnc encoder....

Postby kmisra » Fri Jan 18, 2008 11:23 am

I was getting the same error from earlier...use this HCEnc encoder....also ensure that you have DIVX codecs installed if your AVI follows that format...to know the type of codec to use for your AVI file, download from http://www.headbands.com/gspot/download.html
Junior Member
Posts: 1
Joined: Fri Jan 18, 2008 9:54 am


Postby saskgal » Sun Mar 23, 2008 5:47 pm

Hi everyone......I am new here but I have been watching these boards trying to see if it would help me...I am using AVI2DVD as I just recently bought it...I can not figure it out. and I have been trying for almost 4 days here. I have tried to do everything that has been stated...I AM using NTFS. I downloaded the XVID program from this website as stated http://www.xvidmovies.com/codec/ and it still doesn't work...I still get the Floating point division by zero error
and I can't figure it out. I have a DIVX program on here but I am not sure if that has anything to do with it. I thought I could try to use my divx converter to convert the avi files to divx and burn it, as I was doing this before but even that now shuts down and says DivX Converter Application has encountered a problem and needs to close. We are sorry for the inconvenience. and shuts itself down. I do not understand what is going on and it is really stressing me out. I am truly hoping someone will come to my rescue and save the day....thank you in advance...if I am missing some information that you need to ask or help me out..I will constantly be checking back on here so I will try to answer as best I can...(although by reading the forum...I feel like an amateur on here.....
Junior Member
Posts: 1
Joined: Sun Mar 23, 2008 5:34 pm

Postby DoctorM » Sat May 17, 2008 2:23 am

I just ran into the problem. The video was DivX5 not XviD.
I fixed it because I have ffdshow installed and set to decode DivX video. I had to disable ffdshow's divx decoder.

Pretty much if you don't have the necessary codec installed AND it's not set as the priority decoder for that format you will get the floating point error.
Senior Member
Posts: 31
Joined: Thu Mar 13, 2008 8:24 pm

Postby renneh » Tue Aug 05, 2008 5:57 pm

I was having all of the same issues and I downloaded the xvid codec and still kept getting the error.
so i just moved the file i was about to burn to C: and that solved the problem completely. no more error.
so if you're still having the error i'd try just copy & pasting the video into your c: drive
Junior Member
Posts: 1
Joined: Tue Aug 05, 2008 5:53 pm

Postby DoctorM » Tue Aug 05, 2008 10:32 pm

Avi2DVD is fairly sensitive to symbols, long directory names, etc. in the file name and directories.
So copying to the drive root seems a reasonable fix... how long/what was the name of the directory you were originally using?
Senior Member
Posts: 31
Joined: Thu Mar 13, 2008 8:24 pm

Postby velcr0rapt0r » Sun Feb 08, 2009 6:37 am

I have the same problem, so I downloaded Xvid, my file is in C:/, my file name is good, and it still does it. What do I do?
Junior Member
Posts: 3
Joined: Sun Feb 08, 2009 6:00 am


Return to Avi2Dvd

Who is online

Users browsing this forum: No registered users and 1 guest