Foto2Avi preview error and other issues

Foto2avi is an freeware photo to video converter based on avisynth . It can create cool effects and it is an free video editor. It can handle videos too ! Specially designed for small videos that you can put them on Youtube

Moderators: george, Excalibur!, skyheartblue, roger_rabbit, reburn

Foto2Avi preview error and other issues

Postby Luigi C. » Thu Sep 01, 2011 6:22 pm

Under Windows 7 Ultimate 64-bit, running Foto2Avi in normal mode (not Administrator) does not allow me to preview and generate the AVI file: it returns the error message "Script error: Invalid arguments to function ShowImage (C:\.../Avs\Temp.avs, line 11" in the preview window, even if the picture, video and audio files are in the same directory with a simple name.

If Foto2Avi is run in Administrator mode the preview and AVI generation work but the drag and drop feature not. If the project is large enough (> 200-220 slides), adding more items with the explorer feature makes the buttons labels disappear when the mouse pointer goes over them, then a window containing the error message "Invalid handle" appears, the program becomes unusable and needs to be forcely closed (the close button does not work). I must use the drag and drop feature, but not in Administrator mode.

Now I run Foto2Avi in the normal mode to create, edit (with drag and drop) and save projects, then I run Foto2Avi in the Administrator mode to create the AVI file.
Luigi C.
Junior Member
 
Posts: 5
Joined: Wed Aug 31, 2011 11:48 am

Re: Foto2Avi preview error and other issues

Postby Luigi C. » Sun Sep 04, 2011 6:20 pm

Today I was working on a moderately big job (230 slides); after having completed and saved the project Foto2Avi have given the script error message, even running in Administrator mode.
In order to make the project working I had to remove the subtitles from two slides.
Besides, the program has shown a strange behaviour: sometimes some buttons disappear, and I have to pass the mouse cursor over the buttons locations in order to make the buttons be shown again.

Did someone have similar experiences?
Luigi C.
Junior Member
 
Posts: 5
Joined: Wed Aug 31, 2011 11:48 am

Re: Foto2Avi preview error and other issues

Postby trustfm » Mon Sep 05, 2011 12:42 am

do you use the latest version of foto2avi ?
Yes the drag and drop is a known bug and will be fixed in the next version.
You should always use it as admin or install it on a public directory (foto2avi + avisynth)

Did the photos or paths had strange letters (accented a etc ... ) ?
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Re: Foto2Avi preview error and other issues

Postby Luigi C. » Mon Sep 05, 2011 9:08 pm

I use the ver. 3.3 of Foto2Avi.
The only non-alphanumeric characters in filenames and pathnames are underscore, dash and space.
What about the disappearing buttons?
Luigi C.
Junior Member
 
Posts: 5
Joined: Wed Aug 31, 2011 11:48 am

Re: Foto2Avi preview error and other issues

Postby trustfm » Thu Sep 08, 2011 10:09 pm

this issue is really strange ... i am investigaating on 4 pcs and i cannot reproduce this bug :S
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm

Re: Foto2Avi preview error and other issues

Postby Luigi C. » Fri Sep 09, 2011 8:41 pm

After some editing actions (pictures and videos added, some subtitles added, project saved) on the current project I got the invisible buttons feature:
http://tinypic.com/r/2zrj9xd/7

Pass the mouse cursor over the buttons locations and the "ghost" buttons turn visible again:
http://tinypic.com/r/33onlna/7
Luigi C.
Junior Member
 
Posts: 5
Joined: Wed Aug 31, 2011 11:48 am

Re: Foto2Avi preview error and other issues

Postby Luigi C. » Sun Oct 02, 2011 2:34 pm

I have another Foto2Avi issue: when I try to load an existing project file I get the error "Unable to find the file".
This occurs both running the program in administrator mode or not.
After this error condition raises I can't do anything but clicking on help button or exiting the program.
This issue actually prevents me from using the software at all.
The version of the program is 3.3.
Luigi C.
Junior Member
 
Posts: 5
Joined: Wed Aug 31, 2011 11:48 am

Re: Foto2Avi preview error and other issues

Postby trustfm » Tue Oct 04, 2011 10:12 pm

I will try to reproduce this problem.
Thanks for pointing out your comments are very appreciated.
Have a nice ay
trustfm
Site Admin
 
Posts: 1649
Joined: Sun Feb 27, 2005 4:40 pm


Return to Foto2Avi

Who is online

Users browsing this forum: No registered users and 1 guest

cron